Bitte immer Live Url, PHP Version, Template Version und Template Name angeben
[GELÖST] error in der Log Datei
- Svenoldman
-
Autor
- Premium Mitglied
-
- Beiträge: 90
- Dank erhalten: 2
Bei der Suche warum die Updatequellen deaktiviert werden ist mir folgendes in der error_log Datei aufgefallen.
PHP Warning: Array to string conversion in /home/guehleng/ffw.guehlen-glienicke.de/templates/tp_power/html/layouts/joomla/editors/buttons/button.php on line 32
Dieser Eintrag ist weit über 100 mal drin.
warum gibt es den Fehler in der Template Power button.php Zeile 32 aus?
Bei der Seite ist kein Fehler zu erkennen.
PHP Warning: Array to string conversion in /home/guehleng/ffw.guehlen-glienicke.de/templates/tp_power/html/layouts/joomla/editors/buttons/button.php on line 32
Dieser Eintrag ist weit über 100 mal drin.
warum gibt es den Fehler in der Template Power button.php Zeile 32 aus?
Bei der Seite ist kein Fehler zu erkennen.
von Svenoldman
Dieses Thema wurde gesperrt.
- WM-Loose
-
- Moderator
-
- Beiträge: 3160
- Dank erhalten: 533
Kann ich Ihnen nicht beantworten. Eventuell wird es durch eine andere Erweiterung getriggert. Haben Sie irgendwas sonst noch installiert ? Ich habe das bei meinen Seiten noch nie gehabt. Sie wissen doch: Immer die Versionsangabe zu Joomla; Astroid und Template machen.
Sie sollten die Frage besser einmal Pascal stellen, da Sie htprotect wohl installiert haben und dies seit Wochen diverse Fehler verursacht, die sehr schnell von Pacal bereinigt wurden. Vielleicht ist das auch hier die Ursache ... aber reine Spekulation.
Sie sollten die Frage besser einmal Pascal stellen, da Sie htprotect wohl installiert haben und dies seit Wochen diverse Fehler verursacht, die sehr schnell von Pacal bereinigt wurden. Vielleicht ist das auch hier die Ursache ... aber reine Spekulation.
JP-Admin
Supporter im forum.joomla.de/
Supporter im forum.joomla.de/
Last Edit:2 Monate 2 Wochen her
von WM-Loose
Letzte Änderung: 2 Monate 2 Wochen her von WM-Loose.
Dieses Thema wurde gesperrt.
- WM-Loose
-
- Moderator
-
- Beiträge: 3160
- Dank erhalten: 533
WM-Loose antwortete auf error in der Log Datei ...html/layouts/joomla/editors/buttons/button.php
Posted 2 Monate 2 Wochen her #3
Wie es aussieht, kommt es von einem Template Override in Ihrer Installation was wohl noch von einer älteren Joomla Version als Überbleibsel stammt.
Test: die button.php in button.bak umbennen und testen ob die Errors verschwinden:
...html/layouts/joomla/editors/buttons/button.php
Keine Angst, Joomla verwendet dann die Coredatei:
...layouts/joomla/editors/buttons/button.php
Folgende Vorgehensweise würde ich empfehlen:
Datei umbenennen (nicht sofort löschen).
Joomla-Cache leeren.
Backend öffnen und einen Beitrag bearbeiten.
Prüfen:
Funktionieren die Editor-Buttons?
Erscheint die PHP-Warnung noch?
Werden weiterhin Einträge im error_log erzeugt?
Sollte nach dem Entfernen alles funktionieren und die Warnungen verschwinden, kann die Datei anschließend endgültig gelöscht werden.
Test: die button.php in button.bak umbennen und testen ob die Errors verschwinden:
...html/layouts/joomla/editors/buttons/button.php
Keine Angst, Joomla verwendet dann die Coredatei:
...layouts/joomla/editors/buttons/button.php
Folgende Vorgehensweise würde ich empfehlen:
Datei umbenennen (nicht sofort löschen).
Joomla-Cache leeren.
Backend öffnen und einen Beitrag bearbeiten.
Prüfen:
Funktionieren die Editor-Buttons?
Erscheint die PHP-Warnung noch?
Werden weiterhin Einträge im error_log erzeugt?
Sollte nach dem Entfernen alles funktionieren und die Warnungen verschwinden, kann die Datei anschließend endgültig gelöscht werden.
JP-Admin
Supporter im forum.joomla.de/
Supporter im forum.joomla.de/
Last Edit:2 Monate 2 Wochen her
von WM-Loose
Letzte Änderung: 2 Monate 2 Wochen her von WM-Loose.
Dieses Thema wurde gesperrt.
- WM-Loose
-
- Moderator
-
- Beiträge: 3160
- Dank erhalten: 533
WM-Loose antwortete auf error in der Log Datei ...html/layouts/joomla/editors/buttons/button.php
Posted 2 Monate 2 Wochen her #4
Ist die Sache jetzt gelöst?
Ich würde den Thread dann gerne schließen.
Ich würde den Thread dann gerne schließen.
JP-Admin
Supporter im forum.joomla.de/
Supporter im forum.joomla.de/
von WM-Loose
Dieses Thema wurde gesperrt.
- Svenoldman
-
Autor
- Premium Mitglied
-
- Beiträge: 90
- Dank erhalten: 2
Sorry, bin noch nicht dazu gekommen. Werde die php datei jetzt umbenennen und schauen. Danke erstmal.
Template tp Power
Framework Version: 3.4.2
Template Version: 2.7
Joomla : 6.1.2
Am 15.03.26 kam die Fehlermeldung
Vor den 15-3-26 kamen diese:
[12-Mar-2025 13:52:37 Europe/Berlin] PHP Warning: Undefined property: stdClass::$imgurl in /home/guehleng/ffw.guehlen-glienicke.de/modules/mod_uk_slideshow/tmpl/default.php on line 57
[12-Mar-2025 13:52:37 Europe/Berlin] PHP Warning: Undefined property: stdClass::$imglink in /home/guehleng/ffw.guehlen-glienicke.de/modules/mod_uk_slideshow/tmpl/default.php on line 54
Nach dem 15.3. waren die von slideshow weg.
Template tp Power
Framework Version: 3.4.2
Template Version: 2.7
Joomla : 6.1.2
Am 15.03.26 kam die Fehlermeldung
Vor den 15-3-26 kamen diese:
[12-Mar-2025 13:52:37 Europe/Berlin] PHP Warning: Undefined property: stdClass::$imgurl in /home/guehleng/ffw.guehlen-glienicke.de/modules/mod_uk_slideshow/tmpl/default.php on line 57
[12-Mar-2025 13:52:37 Europe/Berlin] PHP Warning: Undefined property: stdClass::$imglink in /home/guehleng/ffw.guehlen-glienicke.de/modules/mod_uk_slideshow/tmpl/default.php on line 54
Nach dem 15.3. waren die von slideshow weg.
Last Edit:2 Monate 2 Wochen her
von Svenoldman
Letzte Änderung: 2 Monate 2 Wochen her von WM-Loose.
Folgende Benutzer bedankten sich: WM-Loose
Dieses Thema wurde gesperrt.